Monday 3rd August 2026

Inbound Faxing Inbound Faxing | Fixed

Inbound and outbound faxes are experiencing issues. The NocTel team is investigating the issue. Please stand by for further updates.

UPDATE 12:30 PM: An engineer has been dispatched to investigate the issue.

UPDATE 1:15: our engineer is onsite investigating the issue.

UPDATE 3:30 AM : Inbound fax has been restored. If you are still having issue please contact support@noctel.com