Friday 31st July 2026

Bear Prairie Fiber - Bear Prairie | Investigating

Customers in the Bear Prairie area may be experiencing issues that are affecting their internet connection. The NocTel team is investigating the issue. Please stand by for further updates.

UPDATE: A technician has been dispatched and is on site investigating the issue

UPDATE 9:00 AM Pacific: The root cause was identified as power supply failure. The affected unit was replaced and all services are returned to normal at this time.