Monday 27th July 2026

Inbound Fax Issue

Inbound Faxing is currently experiencing the NocTel team has identified the issue. Its currently estimated that inbound faxing will be restored at approximately 18:30 Pacific. Please stand by for further updates.

UPDATE: 18:30 - Additional work is needed to fully restore faxing. Updates to follow.

UPDATE: 2026-07-28 05:00 - This issue has been resolved.