Sunday 30th March 2025

Planned Maintenance - NocTel Fiber @ Ammeter, scheduled 3 days ago

Planned infrastructure maintenance on NocTel's Fiber Network is scheduled for March 30th. Please see the following for details:

-Planned Maintenance Date: Sunday, March 30, 2025

-Planned Maintenance Window: 03:00 - 05:00 AM PT

-Expected Service Impact: NocTel services may be temporarily affected for customers using the NocTel Fiber Network at Ammeter during the maintenance window. Long-term and chronic system stability and use issues shall not occur.

-Maintenance Scope: Necessary infrastructure maintenance to improve backend stability and performance

If you have questions or concerns regarding the planned maintenance, please contact the Support Team (support@noctel.com, +1.503.764.4300). Likewise, if you find your service is impacted post maintenance, please immediately contact support.

UPDATE - 3:04am - Maintenance has begun.

UPDATE - 3:32am - Maintenance has been completed.