Wednesday 31st January 2024

NocTel Fiber Internet Services NocTel Fiber | Connectivity Issues | Investigating

NocTel Fiber is experiencing connectivity problems caused by Internet routing issues. The NocTel team is investigating. Please stand by for further updates.

UPDATE: 2024-01-31 12:15 PM - Our team is onsite working to identify and correct the issue.

UPDATE: 2024-01-31 12:45 PM - Our team has made repairs, and traffic has returned to normal. Our teams are continuing to monitor. If you are still having issue please contact support at help@noctel.com or call 360.837.7400