Wednesday 24th January 2024

NocTel Fiber Internet Services NocTel Fiber | Connectivity Issues | FIXED

NocTel Fiber is experiencing connectivity problems caused by Internet routing issues. The NocTel team is investigating. Please stand by for further updates

UPDATE 2024-01-24 12:30 PM: Our team is currently en route to investigate a potential fiber cut in the Mt. Norway area.

UPDATE 2024-01-24 12:50 PM: Our team is on-site in the Mt. Norway area and has confirmed a fiber cut as the root cause. Our team is currently working on repairs.

UPDATE: 2024-01-24 2:15: At this time our team has completed repairs and network traffic has returned to normal. If you’re still experiencing issues, please reach out to support at help@noctel.com or call us at 360.837.7400.