Thursday 29th September 2022

NocTel Fiber | Investigating

UPDATE 07:50 The team has identified a degraded link and have taken it out of service while repairs are being made. Services should now be stable.

ISSUE 07:23 The NocTel Fiber Network is experiencing routing issues resulting in sporadic Internet service outages. The issue seems localized to the Vernon Rd, Norway, West Ammeter areas. The NocTel team is investigating the issue. Please stand by for further updates.