Monday 11th July 2022

NocTel Fiber Internet Services NocTel Fiber Network | Investigating

UPDATE 16:57 - Our Team has replaced the failed equipment and are continuing to monitor the network for proper operation.

UPDATE 14:15 - Our Team has identified the problem and are currently working on replacing failing equipment. More updates to follow.

ISSUE 12:25 - The NocTel Fiber Network is experiencing routing issues resulting in sporadic Internet service outages. The NocTel team is investigating the issue. Please stand by for further updates.