Tuesday 19th April 2022

Inbound calling Inbound calls | Investigating

Update 6:35 AM Pacific: NocTel has routed around the issue affecting inbound calls and other services. Our team is continuing to monitor the system for stability. Some users may experience a slight delay in receiving voicemails. If you are still encountering issues related to Flow or inbound calls please contact us at support@noctel.com.

UPDATE 6:05 AM Pacific: Inbound call has been restored and affected NocTel Flow instances are now operational. Our team continues to monitor the situation for stability.

NocTel is investigating an issue affecting inbound calls and NocTel Flow. Please stand by for further updates.