Tuesday 15th March 2022

Outbound Faxing Fax Services | Investigating

Faxing services are experiencing issues that are causing processing delays in sending faxes. Our team is investigating the issue. Please stand by for further updates.

UPDATE: 3:30 PM Pacific - Our team is continuing to investigate an issue with outbound faxing via Fax Machine Adaptors (FMAs) and via the NocTel web portal. Inbound faxing is not affected at this time.

UPDATE: 5:57 PM Pacific - Faxing services have been restored.