Monday 31st January 2022

Inbound Faxing Outage

Faxing services are experiencing issues that are causing intermittent problems with faxing. The NocTel team is investigating the matter. Please stand by for further updates.

UPDATE 8:25 AM Pacific: Our teams have identified a server issue impacting inbound faxes and are working to correct it. Outbound faxes at this time remain operational.

UPDATE: 7:30 AM 2022-02-01: Inbound faxing service has been corrected at this time.