Sunday 24th October 2021

Norway NocTel Fiber - Norway & West Ammeter | Investigating

UPDATE MONDAY 3:00p - The maintenance to improve stability during weather events has been completed.

UPDATE 11:00a - NocTel has observed wind-related troubles at one of our locations and will be making improvements to correct this issue.

9:50a - The Norway and West Ammeter fiber services are experiencing issues that is causing an intermittent service impairment. The NocTel team is investigating the issue. Please stand by for further updates.