Tuesday 24th August 2021

PDX20 PDX20 | Resolved

UPDATE 15:55 - Faulty hardware has been replaced and the server is performing normally now. We will continue to monitor for any issues.

UPDATE 15:11 - Technician is on site and currently working to resolve the hardware issue.

UPDATE 14:23 - Issue has been identified as a hardware failure. Technician is en route to resolve the issue.

PDX20 is experiencing issues that are causing issues with inbound/outbound call traffic. The NocTel team is investigating the issue. Please stand by for further updates.