Tuesday 8th September 2020

Vernon Road Vernon Rd power outage - Identified

UPDATE 6:10am - Internet services have been restored on Vernon Rd using temporary power.

UPDATE 4:57am - Trees have damaged the power lines in the Vernon Rd area. Clark PUD has estimated the restoration to be complete by: 9/8/2020, 12:00:00 PM. NocTel is working to restore Internet services using temporary power and estimates this to be online by 06:00 AM.

The Vernon Rd fiber optic network is experiencing issues due to a localized power outage. The NocTel team is awaiting restoration of power. Please stand by for further updates.